Back to overview
Downtime
Google Ads appearing on sites (I-Z), patriotevent.com, and 3 other services are down
Aug 28 at 11:55pm CDT
Affected services
Google Ads appearing on sites (I-Z)
patriotevent.com
therubybuckle.com
haulsafe.com
trailguard.org
Resolved
Aug 29 at 12:10am CDT
therubybuckle.com recovered.
Affected services
Updated
Aug 29 at 12:02am CDT
therubybuckle.com went down and Google Ads appearing on sites (I-Z), patriotevent.com, haulsafe.com, and 1 other resource recovered.
Affected services
Created
Aug 28 at 11:55pm CDT
Google Ads appearing on sites (I-Z), patriotevent.com, haulsafe.com, and 1 other resource went down.
Affected services